Discussion Forums are temporarily in read only mode. All forums are visible but posting is not possible. Please check back shortly.

Thread: Help with HP 54502a


Permlink Replies: 5 - Pages: 1 - Last Post: Feb 5, 2010 5:24 AM Last Post By: tomiwerner
w3kq

Posts: 10
Registered: 03/09/09
Help with HP 54502a
Posted: Mar 9, 2009 6:06 PM
Click to report abuse...   Click to reply to this thread Reply
I recently purchased an HP 54502a scope. I'm really stumped on this one. Applying a low frequency square wave and selecting AC coupling gives a waveform that looks like it went through a differentiator. The scope has two input modules - both do the same thing. I have a "spare" input module - condition unknown- that also does the same thing. All three input modules exhibit the exact same behavior on Channel 1 or 2 - swapping/exchanging does not "move" the problem - it stays. I have the schematic on a 54504a, so I've probed around on the 24 pin IDC connector the attenuator plugs into. What I find (doing some circuit tracing and part number cross referencing) is confusing. I "thought" the input attenuator module output a low freq signal on pin 23 to what appears to be a high speed DG411 analog switch - but that path only seems active in the DC mode - which works fine. The FET gain feedback signal coming out of the LM317 regulator to IDC pin 5 has the same waveform as displayed on the scope, as does IDC pin 4, which I believe is the error signal coming out of the module. Now here's where I'm really confused. The "service manual" for the 54502 says the low freq amp is external to the attenuator, but from all indications, that's a DC restore path which appears to be working. I'm starting to think that all 3 attenuator modules I have are bad, but before I go out and buy a replacement I'd like to see if someone else has come across this problem and knows the solution. I've Googled every conceivable combination of words trying to find some feedback/comments on something like this, but I've not found a thing. This whole loop started because the scope would not hold probe compensation when switching between the AC and DC coupling mode. After a little reading in the service manual, and some input checking, it became clear this problem is worse at low frequencies. It's really depressing to think that all three of my input modules are shot, but that would be par for my luck! Thanks in advance for any thoughts on this one. A schematic of the vertical front end of this scope would be really nice - the 54504a front end is quite different than the 54502a, and circuit tracing a multilayer PCB is not much fun!!!

Rick Jordan, W3KQ
dgun

Posts: 506
Registered: 12/12/05
Re: Help with HP 54502a
Posted: Mar 10, 2009 3:22 PM   in response to: w3kq in response to: w3kq
Click to report abuse...   Click to reply to this thread Reply
This is exactly what you should see when putting slow square waves through a series capacitor (if the capacitor is not large enough for the signal). If you use DC coupling or else measure a higher frequency square wave in AC coupled mode, you should see a square wave. AC coupled mode is like using a high-pass filter, where low frequencies are filtered out.
w3kq

Posts: 10
Registered: 03/09/09
Re: Help with HP 54502a
Posted: Mar 10, 2009 3:43 PM   in response to: w3kq in response to: w3kq
Click to report abuse...   Click to reply to this thread Reply
Thanks for the reply.... so let me make certain that I understand this - It is normal for the scope probe's compensation adjustment to have to be readjusted on this model scope when switching from AC to DC coupling while using the probe calibration output on the back of the scope?????????
dgun

Posts: 506
Registered: 12/12/05
Re: Help with HP 54502a
Posted: Mar 10, 2009 4:22 PM   in response to: w3kq in response to: w3kq
Click to report abuse...   Click to reply to this thread Reply
You should only do probe compensation adjustment in DC coupled mode. Use that compensation for both DC and AC coupling. You can readjust the compensation each time you change attenuation levels, but usually a single compensation is good enough.
w3kq

Posts: 10
Registered: 03/09/09
Re: Help with HP 54502a
Posted: Mar 10, 2009 5:20 PM   in response to: w3kq in response to: w3kq
Click to report abuse...   Click to reply to this thread Reply
Very good - and thank you for the help!
tomiwerner

Posts: 1
Registered: 02/05/10
Re: Help with HP 54502a
Posted: Feb 5, 2010 5:24 AM   in response to: w3kq in response to: w3kq
Click to report abuse...   Click to reply to this thread Reply
Hallo w3kq,

is it possible to get a copy of the schematic of the 54504A . I use it for a repair. My mail adress is tomiwerner@arcor.de.

Many thanks and best regards

tomiwerner

Point your RSS reader here for a feed of the latest messages in all forums