Discussion Forums are temporarily in read only mode. All forums are visible but posting is not possible. Please check back shortly.

Thread: Agilent 8163B Blue Screen of Death


Permlink Replies: 3 - Pages: 1 - Last Post: Feb 10, 2012 2:02 AM Last Post By: mkelly
_biggles

Posts: 2
Registered: 02/07/12
Agilent 8163B Blue Screen of Death
Posted: Feb 7, 2012 11:53 PM
Click to report abuse...   Click to reply to this thread Reply
Hi, I am using an Agilent 8163B mainframe (with 81940A laser module in slot 1 and 81980A laser module in slot 2) to measure BFB fiber laser with a photodiode. The system is controlled by LabView over GPIB. The GPIB commands sweeps laser 2 from 1520 nm to 1570 nm at 5 nm/sec. Output trigger is latched by the start sweep command which starts acquisition. Everything works fine except that at random intervals the 8163b binds up with a blue screen of death with the following message:
System Panic 1 (Software assertion failed)
Module 1 Assertion Failed m_Client == NULL
Task: Interrupt
System halted
Build Information: AT, view KRFV05
Sept 24 2007 12:09:03 V5.01

After complete reboot system is fine.
Any suggestions as to what causes the problem?
mkelly

Posts: 168
Registered: 02/06/07
Re: Agilent 8163B Blue Screen of Death
Posted: Feb 8, 2012 10:02 AM   in response to: _biggles in response to: _biggles
Click to report abuse...   Click to reply to this thread Reply
Hi,
This may be an issue something that was seen a couple times and fixed with a newer firmware version.
We're checking for that version since it isn't shown on the usual web page yet.
Is the firmware on your laser modules 4.84 or older?

One other suggestion in the meantime: if you're not yet using it, the command
[:SOURcen][:CHANnelm]:WAVelength:SWEep:FLAG?
could be used to be sure the laser is ready to start the next sweep.

Regards,
Mike
_biggles

Posts: 2
Registered: 02/07/12
Re: Agilent 8163B Blue Screen of Death
Posted: Feb 9, 2012 12:35 AM   in response to: _biggles in response to: _biggles
Click to report abuse...   Click to reply to this thread Reply
Thanks Mike,

Module firmware is 4.84

It seems to be a problem with GPIB commands. I will try using the HP supplied VI's that run VISA.

Regards

Ian
mkelly

Posts: 168
Registered: 02/06/07
Re: Agilent 8163B Blue Screen of Death
Posted: Feb 10, 2012 2:02 AM   in response to: _biggles in response to: _biggles
Click to report abuse...   Click to reply to this thread Reply
Hi Ian,
OK, we have the updated firmware for this model on the website now.
http://www.agilent.com/find/octfirmware

Under the laser sources you can find the version 4.85 for the compact laser modules.
From the release notes, it seems like this might address your problem.

Good luck and let us know!

Mike

Point your RSS reader here for a feed of the latest messages in all forums