Discussion Forums are temporarily in read only mode. All forums are visible but posting is not possible. Please check back shortly.

Thread: VEE RunTime Error - "Cannot execute file gpib-32.dll"


Permlink Replies: 3 - Pages: 1 - Last Post: Apr 17, 2012 7:11 AM Last Post By: changmeikuan Threads: [ Previous | Next ]
Shakin97

Posts: 2
Registered: 04/06/12
VEE RunTime Error - "Cannot execute file gpib-32.dll"
Posted: Apr 6, 2012 12:16 PM
Click to report abuse...   Click to reply to this thread Reply
Attachment Vee_Error.png (75.7 KB)
Hi all,
I was wondering if anyone knows the fix for this. I have MANY VEE Pro 7 programs written on a previous machine that was running Windows XP(32 Bit).
I got a new machine with Windows 7(64 Bit) and installed VEE Pro 9.3. Trying to run an exsisting simple program, I ran into the Matlab script issue which
I found on the boards (UAC) and that now seems to be fine. But now I'm finding another problem when I try and talk to an instrument. I get the error with the gpib-32.dll file
and I'm not sure how to rememdy this. Any thoughts??

Edited by: Shakin97 on Apr 6, 2012 12:19 PM
changmeikuan

Posts: 210
Registered: 08/07/09
Re: VEE RunTime Error - "Cannot execute file gpib-32.dll"
Posted: Apr 6, 2012 7:59 PM   in response to: Shakin97 in response to: Shakin97
Click to report abuse...   Click to reply to this thread Reply
In your old system, what VISA does it has? Both NI and Agilent? How about the new system?
Shakin97

Posts: 2
Registered: 04/06/12
Re: VEE RunTime Error - "Cannot execute file gpib-32.dll"
Posted: Apr 9, 2012 10:03 AM   in response to: changmeikuan in response to: changmeikuan
Click to report abuse...   Click to reply to this thread Reply
Ni only I believe. I was using a Ni pcmcia card that does not fit into the new PC ports on my new laptop. I had to switch to the Agilent USB controlled GPIB interface(82357B).
changmeikuan

Posts: 210
Registered: 08/07/09
Re: VEE RunTime Error - "Cannot execute file gpib-32.dll"
Posted: Apr 17, 2012 7:11 AM   in response to: Shakin97 in response to: Shakin97
Click to report abuse...   Click to reply to this thread Reply
From the error message, VEE is trying to load NI gpib-32.dll. Do you know if the NI VISA installation includes VISA 32 bit? I used Agilent IO Library Suite more often and not very familiar with NI VISA.

Besides, I pondered how is your program written to talk to the device. Is it using gpib-32.dll or Direct IO? If it is then Direct IO should have use the VISA installed. However, on a 64 bit OS, VEE is running on WOW64 (Windows-on-Windows 64-bit) emulator, thus requires 32 bit of VISA.

Hope this helps.

-mk

Point your RSS reader here for a feed of the latest messages in all forums